Linux最重要的命令之一存在明显的安全漏洞

如果您在Linux或基于macOS的基于Unix的平台中使用了命令行,则可能熟悉“sudo”命令-它使您可以以不同的权限(通常是提升的权限)运行任务。它的强大,但它显然是太强大直到现在。开发人员已经修复了sudo中的一个漏洞,即使您的配置明确禁止,它也可以使您声明根级访问。只要入侵者首先有足够的权限运行sudo,他们就可以在给定的计算机上执行所需的任何操作。

这个怪癖围绕着sudo对用户ID的处理。如果键入用户ID -1或等效的无符号4294967295命令,即使该命令将实际的用户ID记录在日志中,它也会将您视为具有root用户访问权限(用户ID 0)。所涉及的用户标识也不存在于密码数据库中,因此该命令不需要密码即可使用。

Linux用户可以更新到较新的sudo软件包(1.8.28或更高版本)来修复此缺陷。您可能不会立即受到攻击,因为任何攻击者都需要对系统进行命令行控制,然后他们才可以考虑利用该漏洞-那时,您可能会遇到更大的问题。但是,知道如此重要的命令是易受攻击的,这并不令人完全放心。

郑重声明:本文版权归原作者所有,转载文章仅为传播更多信息之目的,如作者信息标记有误,请第一时间联系我们修改或删除,多谢。

相关文章